Original-URL des Artikels: https://www.golem.de/news/libupnp-schwere-upnp-luecke-in-hunderten-von-routern-1301-97235.html    Veröffentlicht: 29.01.2013 17:00    Kurz-URL: https://glm.io/97235

libupnp

Schwere UPnP-Lücke in Hunderten von Routermodellen

Das US-Cert warnt vor einer Lücke in den UPnP-Funktionen, welche vermutlich nahezu alle privat genutzten Router betrifft. Zwar gibt es eine einfache Abhilfe, aber das Stopfen der Lücke dürfte einige Zeit in Anspruch nehmen.

In einem aktuellen Security-Advisory warnt das US-Cert vor einer Lücke in den Funktionen für Universal Plug and Play (UPnP), die die Mehrzahl der Router und andere Geräte für Heimnetzwerke betrifft. Der Fehler steckt in zahlreichen Versionen der ursprünglich von Intel seit dem Jahr 2001 entwickelten Bibliothek "libupnp", die auch für andere Prozessorarchitekturen und Betriebssysteme, darunter Windows, Linux und Mac OS, verwendet wurde.

Nahezu alle Geräte und Programme, die UPnP beherrschen, dürften darauf basieren. Heute sind Folgeversionen von libupnp als "Portable SDK" für die Funktionen bekannt. Laut der Warnung sind alle Versionen von libupnp vor der Nummer 1.6.17 von der Lücke betroffen.

Router reagieren auf UPnP-Anfragen aus dem Internet

Bei drei Funktionen von UPnP, die durch die Bibliothek gesteuert werden, kann es zu einem Pufferüberlauf kommen, über den ein Angreifer Code in das betroffene Gerät einschleusen kann. Dabei ist es auch möglich, über das Internet Zugriff auf ein privates Netzwerk zu erlangen, wie das Cert ausdrücklich feststellt. Die betroffenen Geräte reagieren nämlich auch auf UPnP-Anfragen über das WAN-Interface - also beispielsweise einen DSL-Anschluss - und können so durch Ausnutzen der Lücke kompromittiert werden.

Gerade bei Routern ist der Fehler also kritisch, er dürfte aber auch in vielen anderen Geräten stecken, die UPnP beherrschen. Dazu zählen beispielsweise NAS-Laufwerke, vernetzte Unterhaltungselektronik wie Smart-TVs, Blu-ray-Player und Spielekonsolen sowie Streaming-Clients und Netzwerkkameras. Von diesen Geräten geht aber weniger Gefahr aus, weil ein Angreifer sich innerhalb des privaten Netzes befinden muss.

Lösung: UPnP nur im Router abschalten

Die Abhilfe ist aber ganz einfach und wird vom Cert auch so empfohlen: UPnP muss im Router abgeschaltet werden. Die Funktionen für Universal Plug and Play lassen sich dann auch innerhalb des Netzes von anderen weiterhin nutzen, nur kann der Router nicht mehr von anderen Geräten per UPnP konfiguriert werden. Das ist aber für viele andere beliebte Funktionen in einem Heimnetz wie Streaming von Medien per DLNA oder Airplay oder die Dateifreigabe gar nicht nötig. Vorsichtige Anwender schalten von jeher UPnP im Router ab.

Eine Liste der betroffenen Geräte gibt es noch nicht, das Cert hat aber bereits seit Dezember 2012 über 200 Firmen kontaktiert. Immerhin gaben einige Unternehmen zu, von der Lücke betroffen zu sein. Dazu zählen unter anderem Huawei, NEC, Sony, Belkin, Cisco, Linksys, D-Link und Siemens. Angesichts des Alters der Lücke dürften Hunderte Routermodelle, die in den vergangenen Jahren verkauft wurden, von dem Problem betroffen sein. Abhilfe ist nur durch neue Firmwareversionen möglich, die aber erst erstellt, getestet und verteilt werden müssen.

Entdeckt hat den Fehler das Sicherheitsunternehmen Rapid7, das die Lücke dem Cert mitgeteilt hat. In einem umfangreichen Whitepaper (PDF) beschreibt Rapid7 die Lücke detailliert auch mit Codebeispielen.

Nachtrag vom 30. Januar 2013, 12:10 Uhr

Die Speedport-Router der Telekom sowie Geräte von AVM sollen von der Lücke nicht betroffen sein, wie die Unternehmen Golem.de sagten. Die Hintergründe finden sich in einer aktuellen Meldung.  (nie)


Verwandte Artikel:
Router und Switches: Kritische Sicherheitslücke in Cisco ASA wird ausgenutzt   
(12.02.2018, https://glm.io/132714 )
WLAN-Router: Sicherheitslücke im Mediaserver der Fritzbox   
(22.05.2012, https://glm.io/91956 )
Fritzbox 7583: AVM zeigt neuen Router für diverse Vectoring-Techniken   
(23.02.2018, https://glm.io/132954 )
Hackerangriff auf Thyssenkrupp: Winnti spioniert deutsche Wirtschaft aus   
(16.12.2016, https://glm.io/125103 )
LLVM 6.0: Clang bekommt Maßnahme gegen Spectre-Angriff   
(09.03.2018, https://glm.io/133241 )

© 1997–2019 Golem.de, https://www.golem.de/