Original-URL des Artikels: http://www.golem.de/news/linux-kernel-schwere-sicherheitsluecke-bleibt-ein-jahr-unentdeckt-1302-97826.html    Veröffentlicht: 26.02.2013 08:42

Linux-Kernel

Gefährliche Sicherheitslücke bleibt ein Jahr unentdeckt

Eine Schwachstelle im Netzwerkstack des Linux-Kernels blieb den Entwicklern mehr als ein Jahr verborgen. Hackern war sie jedoch bereits seit Mitte 2012 bekannt. Ein Exploit ist seitdem im Umlauf.

Kernel-Entwickler Matthias Krause hat einen Patch eingereicht, der eine gefährliche Sicherheitslücke im Linux-Kernel schließt. Der Fehler ist in allen Linux-Versionen seit Kernel 3.3 enthalten, der Mitte Januar 2012 erschienen ist. Es gibt Hinweise darauf, dass Hackern der Exploit mindestens seit Mitte 2012 bekannt ist.

Die Sicherheitslücke ist im Netzwerkstack und ermöglicht einen Angriff eines normalen Benutzers, der sich Root-Rechte verschaffen kann. Der Fehler ist im Code der Datei net/core/sock_diag.c . Damit werden Informationen zwischen Prozessen in der Benutzerumgebung und dem Linux-Kernel ausgetauscht. Angreifer können ein speziell präpariertes Netzwerkpaket senden, das einen out-of-bound access auslöst und einen Zugriff mit einfachen Benutzerrechten auf den Kernel erlaubt.

Der fehlerhafte Code wurde im Januar 2012 in Linux 3.3 übernommen und blieb seitdem von den Kernel-Entwicklern unentdeckt. Der russische Sicherheitsexperte Alexander Peslyak stöberte auf Pastebin ein Tar-Archiv auf, dessen Inhalt auf die Sicherheitslücke hinweist. Zwei der darin enthaltenen Dateien tragen einen Zeitstempel, der auf Mitte Juli 2012 datiert ist. Der in dem Archiv enthaltene Code erstellt eine 1 GByte große Datei im Arbeitsspeicher eines angegriffenen Rechners. Außerdem gibt es dort eine Beispieldatei, die Code im Speicher ausführt.

Inzwischen ist die Schwachstelle unter der CVE-Nummer 2013-1763 eingetragen. Bislang hat nur Fedora 18 einen aktualisierten Linux-Kernel erhalten. Für Ubuntu 12.10 ist ein Patch bereits in Arbeit. Andere Distributionen dürften bei der Gefährlichkeit der Sicherheitslücke ebenfalls bald Aktualisierungen bereitstellen. Red Hat und Suse Linux Enterprise Server 11 nutzen ältere Kernel-Versionen und sind von der Schwachstelle nicht betroffen.

Nachtrag vom 26. Februar 2013, 9:37 Uhr

Inzwischen gibt es auch einen gepatchen Kernel für Ubuntu 12.10.

Nachtrag vom 26. Februar 2013, 14:19 Uhr

Im Linux-Kernel 3.8-2 in ArchLinux gibt es ebenfalls einen Fix.  (jt)


Verwandte Artikel:
Kritische Sicherheitslücke im Linux-Kernel 2.6 entdeckt   
(04.11.2009 10:40, http://www.golem.de/0911/70933.html)
Vermutlich aus China: Massive IT-Angriffe auf EADS und Thyssenkrupp   
(24.02.2013 16:00, http://www.golem.de/news/vermutlich-aus-china-massive-it-angriffe-auf-eads-und-thyssenkrupp-1302-97782.html)
Sicherheit: Keylogger verwandelt Linux-Server in Spam-Schleuder   
(21.02.2013 17:08, http://www.golem.de/news/sicherheit-keylogger-verwandelt-linux-server-in-spam-schleuder-1302-97749.html)
Cyberspionage: Chinas beste Hacker sollen für die Armee arbeiten   
(19.02.2013 12:22, http://www.golem.de/news/cyberspionage-chinas-beste-hacker-sollen-fuer-die-armee-arbeiten-1302-97679.html)
Security: Neuer Bot nistet sich im Speicher ein   
(14.02.2013 15:21, http://www.golem.de/news/security-neuer-bot-nistet-sich-im-speicher-ein-1302-97592.html)

© 2014 by Golem.de